BIOS updates to a Mach Speed Viper K8M8MS rev 2 motherboard

I have been having odd problems with a Mach Speed Viper K8M8MSr2 motherboard under Linux. All of my other machines, at this point in time, happen to be the same brand, make, and virtually the same model: those are the “r1” or revision 1 boards.

The problem I am seeing under Linux is:

  1. I cannot load Fedora Core x64 4, 5, or 6 directly on the machine.
  2. When I did get something to load, it had to be on a hard drive smaller than 160GB.
  3. Any update to the kernel results in an machine that cannot boot off of the new kernel.

Now, individually, each one of those problems could be related to a distinctly different thing. However, all together, they just seem weird. Additionally, due to a bug in the BIOS version (A02) that is already on the board, I cannot boot the system off of the net (via a PXE boot) while all of my other machines, even client machines, boot off of the network without any issues. It was recommended by the support folks over at MachSpeed.com that I upgrade the BIOS to the A03 version.
So, I took on the task of upgrading the BIOS to the recommended level (A03). This is not easy, since all of the machine I build now-a-days do not have floppy drives in them. Fortunately, being the tech packrat that I am, I have about 15 floppy drives hanging around. But, first, I thought there had to be a better way, like a bootable CDROM.

After a lot of searching and trial-and-error, I came across Bart’s PE Builder which builds a custom bootable CDROM drive for just about any purpose. This worked out very well to create a bootable CDROM, but, unfortunately, it would not allow me to execute the awdflash.exe binary. It kept claiming that it wasn’t a Win32 executable. πŸ™

After several attempts at other programs and the final failure with the PE Builder, I broke down and started with the floppy procedure. Now, I would have proceeded faster had I realized that Windows XP includes the option to make an MS-DOS bootable floppy. Since I didn’t know or notice that, I hunted all over until I found BIOSMods.com which provided some good floppy images. Of course, I found that site while looking in to an awdflash.exe problem (read further) after realizing that Windows XP could make the disks, but I thought it was worth noting the since since it has some good links to Dr-DOS.

So, I attached a floppy drive to my desktop system, right-mouse clicked on the A drive and selected “Format..”. Notice the option to “Create an MS-DOS startup disk”. I wish I had seen it earlier. πŸ™‚
Windows Format Option
After clicking start, the drive whirred for a little while (Floppies are so inefficiently slow) and finished up. I opened up the disk to take a look at contents:

Windows Format Option
Things looked good. I copied over the awdflash.exe file I got from the Mach Speed BIOS update procedure and the correct BIOS file. There was literally no room left on the disk which worried me a little, but I thought I would cross (burn?) that bridge when I got there. Thinking I would be smart, I created a BIOS folder and placed the two files in to that folder.

I then hooked a floppy drive up to the Linux machine and booted off the floppy I just created (yes, I tested the boot functionality of the floppy on my machine first) and got to an A:\ prompt. I went in to the BIOS folder (cd BIOS) and executed the awflash.exe application (awdflash.exe K8MR2A03.BIN). awdflash.exe eventually came up and it had the BIOS file name pre-filled in. It was flashing “Please Wait” at the bottom of the screen as it was, I assumed, reading the BIOS off of the floppy. It stayed there forever, with the floppy drive spinning. πŸ™

I then tried this same procedure on a test machine I had, and the results were exactly the same. I’m beginning to suspect a problem with the A03 BIOS file. By this time, it was late, and I gave up for the evening.

2 Comments

  1. Rich

    MachSpeed says to go in to the current BIOS, under Misc, and “disable the flash part write protect”.

  2. Rich

    Just to follow up, after making that BIOS change and restarting the entire process, I had no problems updating the BIOS.

    I still couldn’t boot off of the net, and, after an unanswered email to their tech support and a phone call, I was told that it is a known bug with this motherboard that may get fixed in another release of the BIOS.

    I’m not holding my breath, though.

Leave a Reply